Tutorial

Atualizando de 3.0 para 3.2

Imprimir

A atualização para o phpBB 3.2 tornará as MODIFICAÇÕES e os estilos previamente instalados inutilizáveis.

O phpBB 3.2 não é compatível com 3.0 e a maioria dos arquivos anteriores precisará ser removida antes da atualização.

Para atualizar, execute as seguintes etapas:

  1. Certifique-se de que seu servidor atenda aos requisitos para executar o phpBB 3.2: Seção 1.1, “Requisitos”
  2. Faça um backup dos arquivos originais
  3. Faça um backup do banco de dados
  4. Desativar todos os estilos, exceto prosilver
  5. Remova todas as alterações relacionadas ao MOD do banco de dados. O limpador de banco de dados do Support Toolkit pode ser usado para isso.
  6. Definir inglês britânico como o único pacote de idiomas
  7. Faça o download do arquivo do pacote completo do phpBB 3.2
  8. Extraia o conteúdo do arquivo para o seu computador e abra o diretório phpBB3
  9. Exclua os seguintes arquivos do pacote:
    O arquivo config.php
    O diretório images 
    O diretório files
    O diretório store
  10. Em seu site, exclua todos os arquivos da sua placa EXCETO para:
    O arquivo config.php
    O diretório images
    O diretório files
    O diretório store
  11. Carregue o conteúdo do diretório phpBB3 do seu computador para o diretório do seu fórum. Você pode ser solicitado a sobrescrever os arquivos restantes. Se for solicitado a mesclar ou sobrescrever diretórios, opte por mesclá-los.
  12. Atualize o banco de dados:
    Usando seu navegador da Web, visite instalar / na raiz do seu painel. (por exemplo, http://www.example.com/yourforum/install)
    Clique na guia Atualizar
    Clique no botão Atualizar
    Selecione "Atualizar apenas o banco de dados" e clique em Enviar
    Aguarde até que a barra de progresso atinja 100% e uma mensagem indicando que a atualização foi concluída
  13. Excluir o diretório de instalação (pasta install)

Nota
Certifique-se de que o arquivo .htaccess de nível raiz esteja incluído no upload. Alguns clientes FTP não mostram arquivos cujos nomes começam com um ponto e você pode precisar ativar a exibição de arquivos ocultos.
Nota
Se a sua placa fez uso de pacotes de idiomas diferentes do inglês britânico, você precisará baixar uma versão que seja compatível com o phpBB 3.2 em https://www.phpbb.com/languages/
Importante
Ao fazer o upload dos arquivos 3.2 para o seu servidor, NÃO sobrescreva seu arquivo config.php.
Importante
Ao fazer backup de seus arquivos, assegure-se de que seu cliente FTP esteja no modo binário ou transfira arquivos sem extensões no modo binário.
Para obter mais informações, consulte: Base de conhecimento: Transferindo arquivos anexos com o Filezilla